[Printing-summit] QUESTION for operating system vendors/distributors

Wendy Phillips wendy.phillips at sun.com
Mon Aug 21 11:19:14 PDT 2006


This will be a problem for Solaris and any other print system that does 
not use CUPS.

-Wendy

Mark Kirby wrote:
> On Monday 21 August 2006 02:43, Robert L Krawitz wrote:
>> The Gutenprint project is considering a change that would create at
>> least a partial dependency of Gutenprint on the CUPS API
>> (specifically, the PPD file parser in libcups).  How much of a problem
>> would this pose to OS distributors/vendors (e. g. Linux distributions,
>> Mac OS X, Solaris, AIX, etc)?
> 
> Seems NetBSD's Gimp-print package maintainer is behind on developments. I will 
> package Gutenprint this afternoon and submit it for inclusion.
> 
> Adding a cups dependency will at most be a one line change to the package 
> Makefile.
> 
>> Would it be easier if we were to introduce this change in a new minor
>> version (e. g. 5.2) vs. a point release (e. g. 5.0.1)?
> 
> I think 5.2 would be better as you are adding a new dependency and changing 
> some functionality.
> 
> Mark




More information about the Printing-summit mailing list