[Openais] RE: GMI across a router

Steven Dake sdake at mvista.com
Wed Jul 21 15:35:45 PDT 2004

On Tue, 2004-07-20 at 01:02, Sabharwal, Atul wrote:
> >
> >I have not tried gmi within a routed environment.  I would assume this
> >should work, as long as your routes are not over long haul 
> >networks.  If
> >they were over long haul networks, the timeouts in gmi would be too
> >short, which would cause partitions and remerges.
> >
> >I am not sure what exactly you need of the kernel software.  Reading
> >some google hits, you may need some routing software running on the
> >Linux machine.  It appears you may also need a multicast route.
> I configured the kernel but ping to would not get response
> >From all nodes. If I did ping -I eth0, all nodes on eth0
> Responded. If I did ping -I eth1 all nodes in the multicast
> Group on eth1 responded. The ip_forward flag in proc was set to 1
> And IP multicast routing and IP tunneling was set. I even installed
> Mrouted but same result. I did not the Cisco PIM protocol which needs
> Pimd.
> >
> >http://www.linux.com/howtos/Adv-Routing-HOWTO/lartc.multicast.shtml
> >
> >One test to see if your router is working properly is to ping the
> >multicast config group.  You should get responses from every machine on
> >each side of the router.  On startup, the linux kernel on every one of
> >these nodes joins the group address and ping responds to
> >packets to that address.
> >
> >unix# ping (this is the multicast config address)
> What should the routing table on the router look like :
> ( unicast routing worked fine ).
> eth0
> eth1
>   eth0
>   eth1
> eth0
> eth1 
> OR 
>  eth0
>  eth1
> ( rest being same as above ).
> Any tips on how to configure it correctly ?

I'm afraid I dont have many ideas on this Atul.  It might be helpful to
try as a route (vs , or to add a default route
for for eth0 and eth1.

There might be some networking mailing lists which tell how to setup
linux to route to another network that could be pinged.

It sounds like from your message unicast routing works, and multicast
routing works if you bind to a specific interface, but multicast address
routing doesn't work on the default interface.  Is this true?

> Thanks,
> Atul

More information about the Openais mailing list