<html xmlns:v="urn:schemas-microsoft-com:vml" xmlns:o="urn:schemas-microsoft-com:office:office" xmlns:w="urn:schemas-microsoft-com:office:word" xmlns:m="http://schemas.microsoft.com/office/2004/12/omml" xmlns="http://www.w3.org/TR/REC-html40">

<head>
<meta http-equiv=Content-Type content="text/html; charset=us-ascii">
<meta name=Generator content="Microsoft Word 12 (filtered medium)">
<style>
<!--
 /* Font Definitions */
 @font-face
        {font-family:Calibri;
        panose-1:2 15 5 2 2 2 4 3 2 4;}
@font-face
        {font-family:Tahoma;
        panose-1:2 11 6 4 3 5 4 4 2 4;}
@font-face
        {font-family:Consolas;
        panose-1:2 11 6 9 2 2 4 3 2 4;}
 /* Style Definitions */
 p.MsoNormal, li.MsoNormal, div.MsoNormal
        {margin:0in;
        margin-bottom:.0001pt;
        font-size:12.0pt;
        font-family:"Times New Roman","serif";
        color:black;}
a:link, span.MsoHyperlink
        {mso-style-priority:99;
        color:blue;
        text-decoration:underline;}
a:visited, span.MsoHyperlinkFollowed
        {mso-style-priority:99;
        color:purple;
        text-decoration:underline;}
p.MsoPlainText, li.MsoPlainText, div.MsoPlainText
        {mso-style-priority:99;
        mso-style-link:"Plain Text Char";
        mso-margin-top-alt:auto;
        margin-right:0in;
        mso-margin-bottom-alt:auto;
        margin-left:0in;
        font-size:12.0pt;
        font-family:"Times New Roman","serif";
        color:black;}
pre
        {mso-style-priority:99;
        mso-style-link:"HTML Preformatted Char";
        margin:0in;
        margin-bottom:.0001pt;
        font-size:10.0pt;
        font-family:"Courier New";
        color:black;}
span.PlainTextChar
        {mso-style-name:"Plain Text Char";
        mso-style-priority:99;
        mso-style-link:"Plain Text";
        font-family:Consolas;
        color:black;}
span.HTMLPreformattedChar
        {mso-style-name:"HTML Preformatted Char";
        mso-style-priority:99;
        mso-style-link:"HTML Preformatted";
        font-family:Consolas;
        color:black;}
span.EmailStyle21
        {mso-style-type:personal-reply;
        font-family:"Calibri","sans-serif";
        color:#1F497D;}
.MsoChpDefault
        {mso-style-type:export-only;
        font-size:10.0pt;}
@page WordSection1
        {size:8.5in 11.0in;
        margin:1.0in 1.0in 1.0in 1.0in;}
div.WordSection1
        {page:WordSection1;}
-->
</style>
<!--[if gte mso 9]><xml>
 <o:shapedefaults v:ext="edit" spidmax="1026" />
</xml><![endif]--><!--[if gte mso 9]><xml>
 <o:shapelayout v:ext="edit">
  <o:idmap v:ext="edit" data="1" />
 </o:shapelayout></xml><![endif]-->
</head>

<body bgcolor=white lang=EN-US link=blue vlink=purple>

<div class=WordSection1>

<p class=MsoNormal><span style='font-size:11.0pt;font-family:"Calibri","sans-serif";
color:#1F497D'>Hi Denis,<o:p></o:p></span></p>

<p class=MsoNormal><span style='font-size:11.0pt;font-family:"Calibri","sans-serif";
color:#1F497D'><o:p>&nbsp;</o:p></span></p>

<p class=MsoNormal><span style='font-size:11.0pt;font-family:"Calibri","sans-serif";
color:#1F497D'>Thanks for the information. I installed the RPMs on my machine
and then selected them in the &quot;Installed Packages&quot; tab in AppChecker.
This has resolved the RPM checks errors. Earlier I was selecting the RPMs from &quot;Files
and Directories&quot; tab in AppChecker without actually installing them.<o:p></o:p></span></p>

<p class=MsoNormal><span style='font-size:11.0pt;font-family:"Calibri","sans-serif";
color:#1F497D'><o:p>&nbsp;</o:p></span></p>

<p class=MsoNormal><span style='font-size:11.0pt;font-family:"Calibri","sans-serif";
color:#1F497D'>Thanks,<o:p></o:p></span></p>

<p class=MsoNormal><span style='font-size:11.0pt;font-family:"Calibri","sans-serif";
color:#1F497D'>Suresh.<o:p></o:p></span></p>

<p class=MsoNormal><span style='font-size:11.0pt;font-family:"Calibri","sans-serif";
color:#1F497D'><o:p>&nbsp;</o:p></span></p>

<div>

<div style='border:none;border-top:solid #B5C4DF 1.0pt;padding:3.0pt 0in 0in 0in'>

<p class=MsoNormal><b><span style='font-size:10.0pt;font-family:"Tahoma","sans-serif";
color:windowtext'>From:</span></b><span style='font-size:10.0pt;font-family:
"Tahoma","sans-serif";color:windowtext'> Denis Silakov
[mailto:silakov@ispras.ru] <br>
<b>Sent:</b> Monday, September 20, 2010 8:41 PM<br>
<b>To:</b> Suresh Pamidipati<br>
<b>Cc:</b> lsb-discuss@lists.linux-foundation.org; Murthy Esakonu<br>
<b>Subject:</b> Re: [lsb-discuss] LSB AppChecker reporting failures<o:p></o:p></span></p>

</div>

</div>

<p class=MsoNormal><o:p>&nbsp;</o:p></p>

<p class=MsoNormal>Hi,<br>
<br>
the errors you see concern not the application itself, but rpm package format.
It seems that you've created rpm which doesn't meet LSB requirements for RPM (<a
href="http://refspecs.linux-foundation.org/LSB_4.0.0/LSB-Core-generic/LSB-Core-generic/packagefmt.html">http://refspecs.linux-foundation.org/LSB_4.0.0/LSB-Core-generic/LSB-Core-generic/packagefmt.html</a>).
<br>
<br>
I would recommend to get a look at the following article:<br>
<a
href="http://ldn.linuxfoundation.org/article/create-lsb-compliant-packages-dont-alter-your-build-process">http://ldn.linuxfoundation.org/article/create-lsb-compliant-packages-dont-alter-your-build-process</a><br>
<br>
In particular, you can try makelsbpkg script, described here:<br>
<a href="http://ldn.linuxfoundation.org/node/28707">http://ldn.linuxfoundation.org/node/28707</a><br>
<br>
As for particular errors:<br>
<br>
<br>
<o:p></o:p></p>

<div>

<p class=MsoPlainText>RPM header check failed &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;
Failures 36<o:p></o:p></p>

<p class=MsoPlainText>Messages from the test:<o:p></o:p></p>

<p class=MsoPlainText>checkRpmArchive: magic isn't expected value 0x1f8b, found
425a instead<o:p></o:p></p>

</div>

<p class=MsoNormal><br>
Probably archive format inside rpm is not cpio - this can be the case for
latest rpm version. LSB-compliant packages should use cpio.<br>
<br>
<br>
<o:p></o:p></p>

<div>

<p class=MsoPlainText>RPM tags check
failed&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Failures 52<o:p></o:p></p>

<p class=MsoPlainText>Messages from the test:<o:p></o:p></p>

<p class=MsoPlainText>Incorrect RPMTAG_ARCH: expecting i486 or noarch but found
i686<o:p></o:p></p>

</div>

<p class=MsoNormal><br>
LSB RPMs should be built for i486 arch - for example, you should set the
following field in the spec file:<br>
BuildArch: i386<br>
<br>
<br>
<o:p></o:p></p>

<div>

<p class=MsoPlainText>&nbsp;<o:p></o:p></p>

<p class=MsoPlainText>RPM dependencies check failed Failures 712<o:p></o:p></p>

<p class=MsoPlainText>Messages from the test:<o:p></o:p></p>

<p class=MsoPlainText>Unexpected dependency /bin/bash<o:p></o:p></p>

</div>

<p class=MsoNormal><br>
LSB-compliant RPMs should only depend on 'lsb', no other dependencies are
allowed.<br>
<br>
<br>
<o:p></o:p></p>

<div>

<p class=MsoPlainText>&nbsp;<o:p></o:p></p>

<p class=MsoPlainText>RPM archive check failed&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;
Failures 36<o:p></o:p></p>

<p class=MsoPlainText>Messages from the test:<o:p></o:p></p>

<p class=MsoPlainText>Invalid RPMTAG_PAYLOADCOMPRESSOR: expecting gzip but
found bzip2<o:p></o:p></p>

</div>

<p class=MsoNormal><br>
You should use gzip compression.<br>
<br>
<br>
<br>
<br>
<o:p></o:p></p>

<pre>-- <o:p></o:p></pre><pre>Regards,<o:p></o:p></pre><pre>Denis.<o:p></o:p></pre><pre><o:p>&nbsp;</o:p></pre></div>

</body>

</html>