[Bugme-new] [Bug 27962] New: r8712u driver doesn't wakeup correctly from suspend or hibernate

bugzilla-daemon at bugzilla.kernel.org bugzilla-daemon at bugzilla.kernel.org
Mon Jan 31 19:52:37 PST 2011


https://bugzilla.kernel.org/show_bug.cgi?id=27962

           Summary: r8712u driver doesn't wakeup correctly from suspend or
                    hibernate
           Product: Networking
           Version: 2.5
    Kernel Version: 2.6.37
          Platform: All
        OS/Version: Linux
              Tree: Mainline
            Status: NEW
          Severity: normal
          Priority: P1
         Component: Wireless
        AssignedTo: networking_wireless at kernel-bugs.osdl.org
        ReportedBy: alexandre.f.demers at gmail.com
        Regression: No


This bug was already present under 2.6.36.

Before going to suspend or hibernate mode, my network card works fine. After I
resume from either mode, the card doesn't go back online and is not available.
Dmesg keeps showing the following:

r8712u: in r8711_wx_set_scan: bDriverStopped=1
r8712u: in r8711_wx_set_scan: bDriverStopped=1
r8712u: in r8711_wx_set_scan: bDriverStopped=1
r8712u: in r8711_wx_set_scan: bDriverStopped=1
r8712u: in r8711_wx_set_scan: bDriverStopped=1
r8712u: in r8711_wx_set_scan: bDriverStopped=1
r8712u: in r8711_wx_set_scan: bDriverStopped=1
r8712u: in r8711_wx_set_scan: bDriverStopped=1

Then, I unplugged and replugged the USB device and...

usb 5-4: USB disconnect, address 4
usb 5-4: new high speed USB device using ehci_hcd and address 6
usb 5-4: New USB device found, idVendor=0bda, idProduct=8172
usb 5-4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
usb 5-4: SerialNumber: 00e04c000001
r8712u: DriverVersion: v7_0.20100831
r8712u: register rtl8712_netdev_ops to netdev_ops
r8712u: USB_SPEED_HIGH with 4 endpoints
r8712u: Boot from EFUSE: Autoload OK
r8712u: CustomerID = 0x0000
r8712u: MAC Address from efuse = 00:0d:09:a1:09:d9
r8712u: 1 RCR=0x153f00e
r8712u: 2 RCR=0x553f00e
ADDRCONF(NETDEV_UP): wlan0: link is not ready
ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
r8712u: [r8712_got_addbareq_event_callback] mac = 94:0c:6d:f1:2e:b2, seq = 0,
tid = 0
wlan0: no IPv6 routers present

The wireless card is now available and ready to be used.

I also have another USB wireless device plugged at the same time and it wakes
correctly. So it seems only related to r8712u.

-- 
Configure bugmail: https://bugzilla.kernel.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.


More information about the Bugme-new mailing list